Jump to content
  • Announcements

    • Hayley

      Late Autumn Supporter Giveaway   11/27/2020

      I know that winter is well on the way, but I'm sneaking the autumn giveaway in here, right at the end of the season...     I thought this giveaway seemed particularly appropriate for this year: Dear Reader: The Comfort and Joy of Books by Cathy Rentzenbrink.  I'm sure some of you will have heard of this book. It came out in September and has had brilliant reviews. It's been described as a love letter to reading and I think all of us have truly appreciated 'the comfort and joy of books' this year.  It is also a really beautiful hardback. Please excuse my picture-taking skills, it's really hard to get a good picture of something that's shiny!   As always, patreon supporters will be automatically entered into the draw. If you're not a supporter but you'd like to join our patreon you can do so here:  bookclubforum.co.uk is creating a book community | Patreon
Hayley

Forum Fixes - An Update

Recommended Posts

I just wanted to give you all an update on what's happening 'behind the scenes', so to speak, of the forum. I know I haven't been as active as usual on here for a few weeks (that was for a variety of reasons I'll post about elsewhere) but I have been busy trying to find the best solution to the issues we've been having.

 

 I'm sure most of you remember the serious issues we had, first when we kept being kicked from the server, then the failed update and the very long downtime we experienced as a result. At the time I mentioned that things weren't completely fixed and that I'd been advised to get in touch with a web developer if I wanted the issues to be fully resolved. Well (after discovering just how expensive web developers can be!) I did find someone who seemed like they could help us. Only, they were very busy at the time, and then they were on holiday, and then a job was taking longer than expected, and a few weeks ago they told me there was no way they'd be able to get back to us until well after Christmas. So, I started looking for a different solution. 

 

The people who made the software that the forum uses do also host websites, but I didn't go with them originally because a) they were more expensive and b) the software license that Michelle passed on to me was a self-hosted license, and I wasn't sure how easy it would be to change that. But (and this has become a very big and important but) we would have tech support if we could move. For the last week or so I've been in contact with the software developers and moving does sound possible. Somewhat ironically though, the thing holding us back from that move at the moment is related to the thing that caused the original issue. We have an enormous database. And nobody knows why. During the update fiasco we also ended up with multiple copies of our files, which just made things worse. It means that the amount of space we're using would require the kind of hosting package used by big businesses. The kind of packages that are over £100 a month. But we don't need to be taking up anywhere near so much space.

 

Someone from the software company is going to be taking a look at our files and databases, to see how much disc space we actually need. I'm hoping we might know the answer tomorrow or Monday, so keep all your fingers crossed that it's good news!

 

Hopefully this will finally be the answer to our problems and also secure the forum for the future. If not, it will be back to the drawing board, but we'll get there eventually :) 

Share this post


Link to post
Share on other sites

Update: they got back me me a lot quicker than I expected and it's looking very promising. There are a few more details to go through before it's a definite solution but those crossed fingers seem to be working so far! 

Share this post


Link to post
Share on other sites

Ok, I've signed up for the new hosting plan! Just waiting for them to get back to me now. Once I have a scheduled time for the change I'll post an announcement. I've been assured that it's a quick process, we shouldn't be offline for more than a few hours when it happens :) 

Share this post


Link to post
Share on other sites

Hello again everyone! I’m so glad we’re back and I’m so sorry we were offline for so long.

 

A lot has happened since the last time I spoke to you on here but nothing has really changed. Not yet.

 

To cut a long story short, I received an email asking me to move our domain, which I did, and that’s when we went offline. But the team who were going to be moving us over were not the same people I was originally speaking to, and they weren’t actually quite ready to move us. We were essentially on a waiting list. I asked if I should just move us back to the old server for a while and was told no, just hold on, it’s with the right team now...

Days passed and I was getting more and more concerned. I sent a few emails and eventually had a reply apologising for the situation. Someone who was transferring us no longer works for the company, and that had caused problems. They weren’t able to transfer us in the way they were going to. So they tried a different way, but that didn’t work. There was something else they could try but I haven’t heard back from them about that since Friday, so today I decided to move us back to the old server. 
Once the situation at Invision is sorted out we will move. I still absolutely think that’s the best option for the future of the forum, where we have no loading problems and specialist tech support. But it’s just taking too long right now.

I’ve asked them to let me know when a normal move will be possible and I’ll keep you updated with everything here. 
 

Share this post


Link to post
Share on other sites

WOW, thank you a ton for all your work. Very few people would go through what you have gone through to keep this forum active. Again, thank you!

Edited by muggle not

Share this post


Link to post
Share on other sites

Aww, thank you both, that really cheered me up this morning :hug: 

Share this post


Link to post
Share on other sites

http://www.bookclubforum.co.uk/community/index.php?/topic/2804-funny-story-joke-corner/&do=findComment&comment=506083

 

For me the images posted in this thread give weird text errors.. I don't know if it's my computer or whether it doesn't work since the update. If anyone is around and willing, could you check the thread (it's the Funny story & Joke Corner thread) and see if you do see images? Or at least check if you see this one below (a screenshot of said topic and what it looks like to me):

 

ScreenShotBCF002.png

Share this post


Link to post
Share on other sites

Thanks Gaia, I'm really glad it's back too :)

 

Do all the images on that thread show up as text for you, or just that one? I can see all of them apart from the one in your screenshot.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Well done, Hayley! (and thanks for all the hard work!)

Share this post


Link to post
Share on other sites

You’re all so lovely, thank you. I really didn’t do much apart from email and phone people :blush:

 


 

On 18/11/2020 at 12:11 PM, Athena said:

I can see these ones Gaia, are they still missing for you?


If anybody gets a chance could you also click Athena’s links and let me know if the images appear for you? 

Share this post


Link to post
Share on other sites

Thanks for all your efforts Hayley, we've all missed the forum while it has been away.

Share this post


Link to post
Share on other sites
On 19/11/2020 at 3:25 PM, Hayley said:

I can see these ones Gaia, are they still missing for you?


If anybody gets a chance could you also click Athena’s links and let me know if the images appear for you? 

 

They're still missing, unfortunately. I guess it must be just me then, at least the rest of you can see the images!

Oddly enough, I just checked and Google Chrome as guest can see the images, but FireFox logged in as Athena cannot. I updated Firefox yesterday, so that's not it. I don't know.. I guess if it happens again I can try using Google Chrome and see if the image(s) show up.

Share this post


Link to post
Share on other sites

^ Try clearing your Firefox cache/ browsing history, that can sometimes cause issues.

Share this post


Link to post
Share on other sites
On 21/11/2020 at 6:05 PM, Raven said:

^ Try clearing your Firefox cache/ browsing history, that can sometimes cause issues.

 

I did this after reading your post, but it doesn't seem to have helped. Thanks for the tip though!

Share this post


Link to post
Share on other sites
On 21/11/2020 at 8:16 AM, Athena said:

 

They're still missing, unfortunately. I guess it must be just me then, at least the rest of you can see the images!

Oddly enough, I just checked and Google Chrome as guest can see the images, but FireFox logged in as Athena cannot. I updated Firefox yesterday, so that's not it. I don't know.. I guess if it happens again I can try using Google Chrome and see if the image(s) show up.

That is really strange. You can see other images on the forum though can't you? If not maybe go to the 'Site Identity' button and check that the site is being allowed to show images. I guess that could have changed after the firefox update? 

Share this post


Link to post
Share on other sites

I can see a small image in the Autumn Giveway post halfway through your text between paragraphs, but at the bottom it has text and a link that is supposed to be an image, but when I click on it to enlarge it, it gives a file broken icon. You are right that it could have changed after the FireFox update. It seems that FireFox finds the site not completely secure (the lock in the address bar as a yellow triangle with an exclamation mark on it) and maybe that's why it's blocking images..? But it's not giving me an option to unblock them.

 

Quote

orange triangle grey lock 42 : A gray padlock with an orange or yellow triangle indicates that Firefox is not blocking insecure passive content, such as images. By default, Firefox does not block mixed passive content; you will simply see a warning that the page isn't fully secure. Attackers may be able to manipulate parts of the page like displaying misleading or inappropriate content, but they should not be able to steal your personal data from the site

 

This (FireFox help page) says it's not blocking anything though. And it shows you how to unblock things.. but it doesn't look like I can. I guess if there are images in posts in the future I'll try using Google Chrome to view them, at least until I've figured out how to make the images appear in FF.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×